NAME
Solaris::SMF - Manipulate Solaris 10 services from Perl
VERSION
version 1.0.1
SYNOPSIS
Interface to Sun's Service Management Facility in Solaris 10. This module provides a wrapper around 'svcs', 'svcadm' and 'svccfg'.
The SMF in Solaris is a replacement for inetd as well as the runlevel-based stopping and starting of daemons. Service definitions are stored in an XML database.
The biggest advantages in using SMF are the resiliency support, consistent interface and inter-service dependencies it offers. Services that die for any reason can be automatically restarted by the operating system; all services can be enabled or disabled using the same commands; and services can be started as soon as all the services they depend upon have been started, rather than at a fixed point in the boot process.
EXPORT
FUNCTIONS
get_services
Get a list of SMF services, using an optional wildcard as a filter. The default is to return all services.
Returns a list of Solaris::SMF::Service objects.
AUTHOR
Brad Macpherson <brad@teched-creations.com>
COPYRIGHT AND LICENSE
This software is copyright (c) 2015 by TecHed Creations Ltd.
This is free software; you can redistribute it and/or modify it under the same terms as the Perl 5 programming language system itself.